Animation Concepts

Animation is based on a principle of human sight called persistence of vision. If you view a series of related still images in quick succession, you perceive them as continuous motion. Each individual image is referred to as a frame, and the illusion of motion comes from the fact that your visual system retains each frame for a short time after you see it.

A frame is a single image in an animated film.

Traditional Animation Method

Historically, the main difficulty in creating animation has been the effort required of the animator to produce a large number of frames. One minute of animation might require between 720 and 1800 separate images, depending on the quality of the animation. Creating images by hand is a big job. That’s where the technique of keyframing comes in. Most of the frames in an animation are routine, incremental changes from the previous frame directed toward some goal. Traditional animation studios realized they could increase the productivity of their master artists by having them draw only the important frames, called keyframes. Assistants could then figure out what belonged on the frames in between the keyframes. The in-between frames were called tweens. Once all of the keyframes and tweens were drawn, the images had to be inked or rendered to produce the final images. Even today, production of a traditional animation usually requires hundreds of artists to generate the thousands of images needed.

The frames marked 1, 2, and 3 are key frames. The other frames are tweens.

The 3ds Max Method

This program is your animation assistant. As the master animator, you create the keyframes that record the beginning and end of each animated sequence. The values at these keyframes are called keys. 3ds Max calculates the interpolated values between each pair of keys to produce the completed animation.
3ds Max can animate just about any parameter in your scene. You can animate modifier parameters, such as a Bend angle or a Taper amount, material parameters, such as the color or transparency of an object, and much more.

Once you have specified your animation parameters, the renderer takes over the job of shading and rendering each frame. The result is a high-quality animation.

The object's position at 1 and 2 are the keyframed models at different times. The computer generates the in-between frames.

Comparing Frames and Time
Traditional animation methods, and early computer animation programs, are rigidly locked to the concept of producing animation frame by frame. This is okay if you always work in a single format or do not need to specify an animated effect at a precise time. Unfortunately, animation comes in many formats. Two of the more common formats are film at 24 frames per second (FPS) and NTSC video at 30 FPS. Also, the need for accurate time-based animation versus frame-based animation is critical as animation becomes more common for scientific and legal presentation.

Different animation formats have differing frame rates.
3ds Max is a time-based animation program. It measures time, and stores your animation values, with an internal precision of 1/4800 of a second. You can configure 3ds Max to display time in a format best suited for your work, including traditional frames format. See Time Configuration.

Many of the examples in the following sections describe time using the frames method for the sake of tradition and familiarity. Keep in mind that you are really animating using a very precise time-based method, and frames aren’t created until you instruct 3ds Max to render your animation.

Identifying Animation Tools
You can locate the basic animation tools in the following areas of the interface:
Track View—Provides detailed animation editing capabilities in several floating or dockable windows. See Track View.
Track Bar—Provides quick access to keyframes and interpolation controls. Can be expanded for function curve editing. See Track Bar.

Motion Panel—Use this panel to adjust transform controllers that affect all position, rotation, and scale animation. See Working with Controllers.

Hierarchy Panel—Use this panel to adjust all parameters governing the linkage of two or more objects. These include inverse kinematics parameters and pivot point adjustments. See Hierarchy Panel.

Time Controls

Use these controls to move through time in the viewport displays. You can move to any point in time, and play animations in the viewports. The time controls, documented in Animation and Time Controls, include:

- Time slider
- Auto Key button
- Set Key buttons
- Animation playback buttons
- Current frame field
- Key Mode toggle
- Time Configuration button

Time Slider

The time slider works in conjunction with the track bar to allow you to view and edit your animation. The slider itself shows the current frame and lets you move to any frame in the active time segment by dragging. Right-clicking the slider bar opens the Create Key dialog, which lets you create transform keys without keyframing.

- Status line ➤ Time Slider

When Set Key is off, you can copy selected objects’ transform data from a source frame to a destination frame, creating a key at the latter, by right-button dragging the time slider from the source to the destination. Set parameters as necessary on the Create Key dialog, then click OK.

In Set Key mode, holding down (the right mouse button) and dragging the time slider allows you to move a pose in time without losing it in the viewport.

To move one frame back or forward, click the arrow on the left or right side of the time slider, respectively. Or simply click anywhere on the time line to go to that time. In Key Mode, clicking an arrow jumps to the adjacent key.

The Track View Key window displays a time slider as well. The movement of the two time sliders is synchronized. Moving the time slider in the Track View window also moves the time slider below the viewports and vice versa.

Procedures

To toggle the time slider, do the following:

- On the Enhanced menu ➤ Animation menu ➤ Timeline panel, click Show Time Slider.

To move to a specific frame in the animation, do one of the following:

- Drag (scrub) the time slider right or left until the frame number is displayed on the time slider.
- Type the frame number into the current frame field in the time controls and press Enter.

www.a2zpapers.com
We provide GNDU question papers, PTU question papers, PU question papers, LPU question papers, GNA university question papers, PSEB question papers, HPSEB question papers, ICSE question papers and CBSE question papers.
• Click in the empty track to either side of the time slider. The time slider will jump to your cursor position. This is faster than dragging the time slider.

**To move forward or back by one key, do one of the following:**

By default, **Key Mode** is off, and these controls move a frame at a time. To move between keys, click the Key Mode Toggle button; this turns on Key Mode. When Key Mode is on, the button looks like this:

- Click the < or > button at either end of the time slider.
- Press the < or > key on the keyboard.
- When Key Mode is off, click the Next Frame or Previous Frame button in the time controls.
- When Key Mode is on, click the Next Key or Previous Key button in the time controls.

**To move to the first or last frame of the active time segment:**

- Use the time control buttons (Go To Start) or (Go To End).

**To display SMPTE time code on the time slider:**

- In the time controls, click (Time Configuration), and then under Time Display, choose SMPTE.

**To display subframes on the time slider:**

- In the time controls, click (Time Configuration), and then under Time Display choose Frames:TICKS or MM:SS:TICKS.
  Each frame is divided into subframes.

**To use the time slider to adjust animation, do one of the following:**

- To copy a pose from one frame to another, with Auto Key on or off, and Set Key off, right-click the time slider and drag to a new location.
  The Create Key dialog appears with Source Time set to the frame you were on when you right-clicked, and Destination Time set to the frame to which you moved the time slider. Toggle the Position, Rotation, and Scale checkboxes as necessary and then click OK to create a key at the destination frame for the pose at the source frame.

- In Set Key mode, if you have posed your character on the wrong frame, right-click and drag the time slider. The pose is moved in time to the new time slider position. Click the Set Key button to set the keys.

**To scrub the animation with the mouse but without dragging:**

1. Open Customize User Interface and on the Keyboard panel, click in the Action list and then press T to jump to the T section. Scroll down to find Time Slider Capture Toggle and click it.
2. Click the Hotkey field and then press a keyboard combination to assign as a keyboard shortcut; for instance, Ctrl+T. Click the Assign button.
3. Close the Customize User Interface dialog and then press your hotkey for Time Slider Capture Toggle.
4. Move the mouse left and right without pressing any buttons.
   The time slider moves in tandem with the mouse.
5. To exit this mode, press the hotkey again or click any mouse button.
By default, the active time segment is from frame 0 to frame 100. The slider displays time in frames, **SMPTE numbers**, or other measurements, depending on the current setting in the **Time Configuration dialog**.

The slider bar displays the current frame, followed by a slash (/), followed by the total frames in the active time segment. For example 25/100 means frame 25 of 100 frames. The current frame also appears in the current frame field. If animation exists in the scene, it's played back as you drag the time slider.

The buttons at the left and right ends of the time slider move the animation one frame backward and forward, respectively, like the Previous Frame and Next Frame buttons in the time controls. If **Key Mode** is on, these buttons duplicate the Previous Key and Next Key buttons instead.

**Key Mode** can jump to all the keys or only the transform keys, depending on the Key steps setting in the **Time Configuration dialog**.

**TIP:** With one or more objects selected, right-click the slider bar to open the Create Key dialog. This lets you create Position, Rotation, or Scale keys without using Auto Key. It also lets you copy keys easily from one frame to another.

---

**Track View**

**Track View** provides two different graph-based editors for viewing and modifying animation data in your scene. You can also use it to assign animation controllers to interpolate or control all the keys and parameters for the objects in your scene.

- Main toolbar ➤ (Curve Editor (Open))
- Graph Editors menu ➤ New Track View
- Graph Editors menu ➤ Track View - Curve Editor
- Graph Editors menu ➤ Track View - Dope Sheet
- Graph Editors menu ➤ Saved Track View ➤ Choose a saved Track View.
- Right-click the active viewport. ➤ Quad menu ➤ Transform quadrant ➤ Curve Editor or Dope Sheet
- Click or right-click the Point-Of-View (POV) viewport label. ➤ Point-Of-View (POV) Viewport Label Menu ➤ Extended Viewports ➤ Track View ➤ Choose New or a saved Track View.

**Track View** uses two different modes: Curve Editor and Dope Sheet. Curve Editor mode displays animation as function curves, while Dope Sheet animation appears as a spreadsheet of keys and ranges. Keys are color-coded for easy identification. Some **Track View** functions, such as moving and deleting keys, are also available on the track bar near the time slider, which can be expanded to show curves as well. The Curve Editor and Dope Sheet open by default as floating windows, but you can also dock them under the viewports at the bottom of the interface, or even open them in a viewport. You can name **Track View** layouts and store them in a buffer for later reuse. **Track View** layouts are stored with the **MAX** scene file.

---

**Track View — Curve Editor**
Track View — Dope Sheet (Edit Keys)

**Typical Uses for Track View**
Track View can perform a variety of scene management and animation control tasks. Use Track View to:

- Display a list of objects in your scene and their parameters.
- Change key values.
- Change key timing.
- Change controller ranges (see procedure).
- Change interpolation between keys.
- Edit ranges of multiple keys.
- Edit blocks of time.
- Add sound to your scene.
- Create and manage notes about the scene.
- Change the behavior of the animation outside the range of keys.
- Change controllers for animated parameters.
- Select objects, vertices, and hierarchies.
- Navigate the modifier stack in the Modify panel by clicking the modifier items in the Track View Hierarchy.

**NOTE:** Tracks are created for animated vertices in Track View. A Bezier Point3 controller is the default vertex interpolation controller.

**Procedures**

**To change the frames in which a controller takes effect:**
When you apply a controller or constraint to an object's motion, the frame range over which controller takes effect is determined by the current active time segment. If you then change the active time segment or the animation length, the duration of the controller's influence doesn't change. Sometimes applying a
controller (such as Path Constraint) automatically sets keys that you can use to change this range. But others, such as Noise controllers, don’t set keys. In such cases, follow this procedure:

1. Select the object, and then right-click it and choose Curve Editor from the menu.
2. Expand the object hierarchy to find the track or tracks to adjust.
3. From the Editor menu, choose Dope Sheet.
5. Adjust the range duration by dragging its endpoints, or its position in the animation by dragging between endpoints.

For more information, see Dope Sheet Introduction.

To select keys in Track View (either mode), do any of the following:

- Click the key to select an individual key.
- Drag a selection rectangle around keys to select multiple keys.
- Hold down the Ctrl key and click to create discontinuous multiple key selections.

NOTE: If you are in Dope Sheet – Edit Ranges mode, you can use Select Time to select multiple keys.

To delete keys in Track View (either mode):

1. Select keys on the curve, or on the dope sheet.
2. Press Delete to delete the selected keys.

To force Track View to always display on a second monitor:
If you are running a dual-monitor setup, you can force Track View to display on the right-hand monitor by editing a script.

1. On the main toolbar, right-click (Curve Editor (Open)), and then choose Edit Macro Script.
2. Locate the line that reads:
   if (trackviews.open "Track View - Curve Editor" layoutName:"Function Curve Layout") == true then
3. Replace that line with this one:
   max_window = getMaxWindowSize() --get Desktop size if (trackviews.open "Track View - Curve Editor"
   layoutName:"Function Curve Layout" pos:[max_window.x/2,0] height:max_window.y
   width:(max_window.x/2) ) == true then
4. Save the script and restart 3ds Max.

This should open the Track View in a new session over the right half of the desktop. Assuming that a dual-monitor setup reports twice the width, this will force the Track View on the second monitor. On a single monitor, it opens it over the right half of the monitor. Of course, you could enter your own numbers like pos:[1024,0] height:768 width:1024 in case you are running two monitors at 1024x768.

To open Track View in a viewport:

- Click or right-click the Point-Of-View (POV) viewport label, and then from the POV viewport label menu choose Views ➤ Extended Viewports ➤ Track View ➤ New, or choose the name of a saved Track View.

Auto Key Animation Mode
Auto Key

The Auto Key button toggles the keyframing mode called Auto Key. While Auto Key is on, changes to objects’ position, rotation, and scale are automatically keyframed (recorded). When Auto Key is off, these changes are applied to frame 0.

- Status bar ➤ Time controls ➤ Auto Key (Toggle Auto Key Mode)
- Keyboard ➤ N

Alternatively, you can create keyframes manually with Set Key mode, which allows you to add keyframes explicitly with the Set Keys button.

Auto Key

When Auto Key mode is active, the Auto Key button is red, as are the active viewport outline and the time slider. These indicators serve to remind you that you are in Animate mode, and that you are setting keyframes with your actions.

**WARNING:** Be sure to turn off Auto Key after keyframing, or you will inadvertently create unwanted animation. Use Undo to remove the unwanted animation. Be careful; it’s easy to forget. Within an existing animation, you can create keyframes for transforms without the use of Auto Key mode by right-clicking the time slider and then setting the source and destination time. For example, you can use this function to copy an existing Move key to a later frame, so an object pauses its motion momentarily (to keep the object still, you must use linear or step interpolation). You can also set keyframes for other animatable parameters in Track View and the Motion panel without using Auto Key.

**Procedures**

To animate an object using Auto Key:

1. Click **Auto Key** to turn on Auto Key mode.
   
   The Auto Key button, the time slider channel, and the highlight border around the active viewport all turn red.

2. Drag the time slider to a time other than 0.

3. Do one of the following:

   - Move, scale, or rotate an object.
   - Change an animatable parameter.

   For example, assume you start with a cylinder that has not been animated yet and therefore has no keys. You turn on Auto Key, go to frame 20, and rotate the cylinder 90 degrees about its Y axis. This action creates rotation keys at frames 0 and 20. The key at frame 0 stores the original orientation of the cylinder, while the key at frame 20 stores the animated rotation of 90 degrees. When you play the animation in the viewport, the cylinder rotates 90 degrees about its Y axis over 20 frames.

4. Turn off **Auto Key** when you are done.

**Example: To animate an object between three points using Auto Key:**

1. Turn on **Auto Key**.

2. Drag the time slider (to frame 25, for example).

3. Move the object from point A to point B.
3ds Max creates a Move key at frames 0 and 25. The establishing key at frame 0 describes the object’s position at point A. The key at frame 25 describes the object’s position at point B.

4. Drag the time slider (to frame 50, for example).

5. Move the object from point B to point C.
3ds Max creates a Move key at frame 50 that describes the object’s position at point C.

6. Click (Play Animation).
The object moves from point A to point B over frames 0 to 25, then proceeds to point C over frames 26 to 50.

7. The Play button turns into a Stop button. Click (Stop Animation) to stop playback.
The position of the object in between the keyframes is determined by the interpolation type used by the controller. Right-click the keys in the track bar and select the transform key to see the controls for adjusting the timing of the in-betweens.

8. Turn off Auto Key.

**To remove the animation from a scene and start again:**
1. Choose Application menu ➤ New ➤ Keep Objects And Hierarchy.
   All the objects remain in the scene, but all keyframes have been removed.
   **TIP:** To remove the animation from just certain objects, delete their keys in Track View.

**Example: To animate a deformation curve of a loft object:**
1. Turn on Auto Key.
2. Use the time slider to set a current frame.
3. Select one or more control points in the deformation curve of a loft object.
4. Use (Move Control Point) or (Scale Control Point) to transform the control points.

**To animate a hierarchy with IK interactively:**
1. Select any hierarchy that does not already have an IK Solver applied.
2. On the Hierarchy panel, click IK.
3. Turn on Auto Key.
4. On the Inverse Kinematics rollout, turn on Interactive IK.
5. Select and move objects in the IK structure on different frames.
   **NOTE:** This will work on linked hierarchies and bones that do not already have an HI, HD, or Limb Solver applied. This technique allows you to animate hierarchies using IK methods without applying any IK solver.

**Set Key Animation Mode**

Set Key Animation mode allows you to create keys for selected objects individual tracks using a combination of the Set Keys button and Key Filters. Unlike Auto Key, Set Key mode gives you control over...
what you key and when. It allows you to pose a character (or transform any object) and then if you like it, use that pose to create keys. If you move to another point in time without keying, your pose is discarded. Set Key also works with object parameters.

- Keyboard ➤ K (3ds Max mode)
- Keyboard ➤ .S (Maya mode: See Interaction Mode Preferences)

You can try out different values and then when you have what you like use it to create keys. Combine this with keyable tracks in the Curve Editor to create keys on just the object parameters you want to key.

Set Key Workflow

To animate something using Set Key mode, you first turn on Set Key Mode. You can then select the object you want to animate and use the Key Filters button to set which tracks you want to keyframe. You can also use Show Keyable icons in Track View edit windows to make individual tracks keyable or not. With all this setup work completed, you can create keys by clicking the Set Key button (the large button with the key icon) or using Keyboard shortcut (K). Move ahead in time, then make changes to your character or object (transforms or parameter changes) and click Set Keys to use those changes to create keys. If you do not click the Set Keys button and move to another frame the object changes will be lost, as if you had never made them. This is fundamentally different behavior from Auto Key mode, where you would need to use undo to lose the changes you made. Drag the time slider with (the right mouse button) to move a pose or transform to a different point in time.

For faster workflow you can define keyboard shortcuts for the Key Filters and Show Keyable tools by going to Customize menu ➤ Customize User Interface and assigning keystroke combinations in the Main UI group.

Procedures

To animate using Set Key mode:

1. Turn on (Toggle Set Key Mode).
2. Select the objects you want to keyframe, and then right-click and choose Curve Editor.
3. On the Track View toolbar, click (Show Keyable Icons), then use the keyable icons in the controller window to define which tracks will be keyed.
   A red key means the track will be keyed. Click a key to toggle its keyable status.
4. Click (Key Filters) and then turn on the tracks you want to keyframe. By default, Position Rotation, Scale, and IK Parameters are on. For this example, turn off Rotation and Scale.
5. Go to a frame at which you want to set a key.
6. Move an object.
7. Click (Set Keys).
   The Set Keys button flashes red to show that 3ds Max has set a key, and a key appears on the track bar.
   Repeat this process, moving the time slider and setting keys.

To keyframe all parameters using Set Key mode:

1. Turn on (Toggle Set Key Mode).
2. In the viewport, select the objects to which you want to add keyframes.

3. Click **Key Filters** (Key Filters) and then turn on Key All.

4. Move the time slider to the frame where you wish to set keys.

5. Click **Set Keys** (Set Keys).
   
   3ds Max adds keys to all keyable parameters.

**To move a pose or position in time without update:**

1. Turn on **Set Key** (Toggle Set Key Mode).

2. Move to a particular frame (let's say, frame 20).

3. Pose your character or position your objects.

4. Move your cursor over the time slider, then drag with the right mouse button. The time slider moves, but the position does not change. The pose or position is maintained and transferred to the new point in time.

5. When you are at the appropriate frame, set the pose or position keys by clicking **Set Keys** (Set Keys).

**Interface**

**Set Key**

Toggles Set Key mode.

**Set Keys**

Click this button to set a key on each track in the selection set. It checks that the tracks are keyable, and that Key filters allow the tracks to be keyed. If both these are satisfied, a key is set. Set Keys also sets keys in Auto Key mode and in Layout mode (when neither Auto Key nor Set Key is turned on).

**Selection List**

Provides quick access to Named Selection Sets and track sets while working in Set Key animation mode. Use this to switch quickly among different selection sets and track sets.

**NOTE:** Choosing a selection set from the list does not select objects in the viewports. To accomplish this, use the Named Selection Sets feature.

**NOTE:** Selection set names appear between braces (example: {Biped Arms}) while track set names appear between square brackets (example: [Throw Baseball]).

**Key Filters**

Opens the Set Key Filters dialog (see following) where you can specify the tracks on which keys are created when you use Set Keys.

**Set Key Filters dialog**

Turn on the tracks you want to key. Default=Position, Rotation, Scale and IK Parameters.
The following options are available:

- **All** Provides a quick way to place keys on all tracks. When All is on, the other toggles are unavailable. Clicking Set Keys with the All filter on results in keys placed on all keyable tracks.
- **Position** Allows position keys to be created.
- **Rotation** Allows rotation keys to be created.
- **Scale** Allows scale keys to be created.
- **IK Parameters** Allows inverse kinematic parameters to be keyframed.
- **Object Parameters** Allows object parameters to be keyframed.
- **Custom Attributes** Allows custom attributes to be keyframed.
- **Modifiers** Allows modifiers to be keyframed.
  
  **TIP:** When you turn on Modifiers, also turn on Object Parameters so you can keyframe gizmos.
- **Materials** Allows material properties to be keyframed.
- **Other** Allows other parameters that don’t fall in the above categories to be keyframed using the Set Key technique. This includes such settings as helper properties and look-at controller tracks for target cameras and lights.

**WARNING:** If you turn on Object Parameters, all the object parameters of an object will then receive keys, unless you have turned off the tracks using Keyable on the Controller submenu of Track View Edit menu. The same advice applies to Materials.

**TIP:** You can also set keys on spinner settings by holding down the Shift key and right-clicking the spinner.

**Time Configuration**

The Time Configuration dialog provides settings for frame rate, time display, playback, and animation. You use this dialog to change the length of your animation, or stretch or rescale it. You also use it to set the start and end frames of the active time segment and your animation.

- **Status bar ➤ Time controls ➤ (Time Configuration) ➤ Time Configuration dialog**

**Procedures**

**To define the active time segment:**

1. Click (Time Configuration).
2. In the Time Configuration dialog ➤ Animation group, set Start Time to specify the beginning of your active time segment.
3. Do one of the following:
   - Set End Time to specify the end of your active time segment.
   - Set Length to specify the amount of time in the active time segment and automatically set the correct End Time.

You can enter positive or negative values in any spinner, but you must use the same format used by the time display.

You can change the active time segment without affecting the keys you’ve created. For example, if you have keys scattered over a range of 1000 frames, you can narrow your active time segment to work on only frames 150 to 300. You can only work on the 150 frames in the active segment, but the remainder of the animation stays intact. Returning the active segment from 0 to 1000 restores access and playback of all the keys.
Changing the active time segment has the following effects: it restricts the range of time you can use with the time slider, and it restricts the range of time displayed when using the animation playback buttons. The default setting for the active time segment runs from frames 0 to 100, but you can set it to any range.

To stretch out your existing animation over a longer time:
1. In the Time Configuration dialog ➤ Animation group, click Re-scale Time.
2. Change the value in Length to be the number of frames you want the action to fill.
3. Click OK.
   The animation is rescaled to the new number of frames. This also works to compress animations into a shorter space of time. To avoid losing frames during the rescaling, see “To use sub-frame animation” in this set of procedures.

To add frames onto your existing animation:
This procedure adds new frames to the end of your animation, without affecting your existing work.
1. In the Time Configuration dialog ➤ Animation group ➤ End Time field, enter the number of the last frame of the animation.
   For example, if your existing animation is 100 frames long and you want to add 50 frames, enter 150.
2. Click OK.
   The number you entered is now the new length of the animation, shown on the time slider.

To move to an exact time in your animation:
- In the Time Configuration dialog ➤ Animation group, enter the frame number in the Current Time field, and press Enter.
   The viewport updates to this frame.

To set the frame rate of your animation:
In the Time Configuration dialog ➤ Frame Rate group, do one of the following:
1. Choose one of the standard frame rates such as PAL or NTSC.
2. Choose Custom, and specify a frame rate in the FPS (frames-per-second) field.

To configure viewport playback:
- In the Time Configuration ➤ Playback group, turn on or off the Real Time and Active Viewport Only boxes.

To play your animation in reverse or back and forth:
1. In the Time Configuration ➤ Playback group, turn off the Real Time.
2. Choose the direction of the animation playback by selecting Forward, Reverse, or Ping-Pong.
3. Play the animation in the viewport using (Play Animation) or the / key.

To play your animation only once:
1. In the Time Configuration ➤ Playback group, turn off Loop.
2. Choose the direction of the animation playback by selecting Forward, Reverse or Ping-Pong.
3. Play the animation in the viewport using (Play Animation) or the / key.
   The animation will play once and stop.

To play your animation in multiple viewports:
1. In the Time Configuration ➤ Playback group, turn off Active Viewport Only. Click OK.
2. Play your animation.
   The animation now plays in all four viewports.

**To use sub-frame animation:**

1. In the Time Configuration ➤ Time Display group, turn on FRAME:TICKS or MM:SS:TICKS. Click OK.
2. Move the time slider to set keyframes in between keys.
   
   **TIP:** Use this when you scale an animation down from a longer length to ensure that you won’t lose any keys. You can then move the keys to frames and revert to frames without ticks.

**To play an animation with sound:**

- In the Time Configuration ➤ Playback group, be sure you have Real Time turned on. If Real Time is not on, the sound will not play back during the animation.

**Interface**

These are the controls for the Time Configuration dialog. You can display this dialog by right-clicking any of the time control buttons to the right of the Auto Key button.

**Frame Rate group**

These four option buttons, labeled NTSC, Film, PAL, and Custom let you set the frame rate in frames-per-second (FPS). The first three buttons force the standard FPS for that choice. The Custom button lets you specify your own FPS by adjusting the spinner.

**FPS (Frames Per Second)**

Sets the frame rate of your animation in Frames per Second. Use frame rates of 30 fps for video, 24 for film, and lower rates for web and media animations.

**Time Display group**

Specifies the method for displaying time in the time slider and throughout 3ds Max (in frames, in SMPTE, in frames and ticks, or in minutes, seconds, and ticks). For example, if the time slider is at frame 35, and the Frame Rate is set to 30 fps, the time slider would display the following numbers for the different Time Display settings:

- Frames: 35
- SMPTE: 0:1:5

**FRAME: TICKS: 35:0**

**MM:SS: TICKS: 0:1:800**

SMPTE is the Society of Motion Picture Technical Engineers standard used to measure time for video and television production.

**Playback group**

**Real Time-Real Time** causes viewport playback to skip frames to keep up with the current Frame Rate setting.

When Real Time is off, viewport playback occurs as rapidly as possible and displays all frames.
Active Viewport Only - Causes playback to occur only in the active viewport. When off, all viewports display animation.

Loop - Controls whether the animation playback occurs only once, or repeatedly. When on, playback repeats until you stop it by clicking an animation control button or the time slider channel. When off, the animation plays once and then stops. Clicking Play rewinds to the first frame and plays again.

Speed - A choice of five playback speeds is available: 1x is normal speed, 1/2x is half speed, and so on. The speed settings affect only the playback in the viewports. Default=1x.

These speed settings can also be used with the Motion Capture utility.

Direction - Set the animation to play forward, reverse, or ping-pong (forward and then reverse, repeating). This affects only the playback in the interactive renderer. It does not apply when rendering to any image output file. These options are available only when Real Time is off.

You can recall these settings automatically upon startup or reset by saving a maxstart.max file. See Startup Files and Defaults.

Animation group

Start Time / End Time - Sets the active time segment displayed in the time slider. Choose any time segment before or after frame 0. For example, you can set an active time segment from -50 to 250.

Length - Displays the number of frames in the active time segment. If you make this greater than the total frames in the active segment, the End Time field increases accordingly.

Frame Count - The number of frames that will render. Always the length plus one.

Current Time - Specifies the current frame for the time slider. As you adjust this, the time slider moves accordingly and the viewport updates.

Re-scale Time - Click to open the Re-scale Time dialog.

Key Steps group

Controls in this group let you configure the method used when you turn on Key Mode.

Use TrackBar - Allows key mode to honor all keys in the track bar. This includes any parameter animation in addition to transform keys.

To make the following controls available, turn off Use TrackBar.

Selected Objects Only - Considers only the transforms of selected objects when you use Key Steps mode. If you turn this off, the transforms of all (unhidden) objects in the scene are considered. Default=on.

Use Current Transform - Disables Position, Rotation, and Scale and uses the current transform in Key Mode. For example, if the Rotate button is selected in the toolbar, you stop at each rotation key. If none of the three transform buttons are on, Key Mode considers all transforms.

To make the following control available, turn off Use Current Transform.

Position, Rotation, Scale - Specifies which transforms are used by Key Mode.

Clear Use Current Transform to make the Position, Rotation, and Scale checkboxes available.

Show Ghosting

Ghosting is a method of displaying wireframe "ghost copies" of an animated object at a number of frames before or after the current frame. Use it to analyze and adjust your animation. Ghosts that overlap indicate slower motion; ghosts that are spread further apart show faster motion.

- Standard menu: Views menu ➤ Show Ghosting
- Enhanced menu: Animation menu ➤ Display ➤ Show Ghosting

When this command is active, ghosting is displayed for selected objects in the scene. Only currently selected objects display the ghosting.
Ghosting helps to visualize animation.
To change Ghosting parameters, open the Manage menu and choose Customization ➤ Preferences. In the Viewport panel ➤ Ghosting group of the Preferences dialog you can specify the number of ghosting frames, whether to ghost before or after the current frame, or both, and you can also show frame numbers with the ghosts.

Procedure

To show wireframe ghost copies of an animated object:

- Choose Animation menu ➤ Display ➤ Show

Track View Menu Bar

A menu bar appears at the top of Track View in both Curve Editor and Dope Sheet modes and the expanded track bar layout. The Track View menu bar is contextual; it changes slightly between Curve Editor and Dope Sheet modes.

- Track View ➤ Menu bar

The commands available on the Track View menus can also be accessed on the Curve Editor and Dope Sheet toolbars. Certain tools, however, appear only on the toolbars, and do not appear in the menus. The Editor menu lets you switch between the Curve Editor and Dope Sheet when working in Track View.

- Track View ➤ Editor menu.

You will see the following options: Dope sheet and Curve Editor

Track View Menu Bar

A menu bar appears at the top of Track View in both Curve Editor and Dope Sheet modes and the expanded track bar layout. The Track View menu bar is contextual; it changes slightly between Curve Editor and Dope Sheet modes.

- Track View ➤ Menu bar

The commands available on the Track View menus can also be accessed on the Curve Editor and Dope Sheet toolbars. Certain tools, however, appear only on the toolbars, and do not appear in the menus.

Definitions:

- **Editor Menu** - The Editor menu lets you switch between the Curve Editor and Dope Sheet when working in Track View.

- **Edit Menu** - The Edit menu gives you tools for adjusting animation data and working with controllers.

- **View Menu** - The View menu is present in both Dope Sheet and Curve Editor modes, but not all commands are available in both. Its controls let you adjust and customize how items in Track View appear.

- **Curves Menu** - The Curves menu is available when working in Track View in both Curve Editor and Dope Sheet modes, but not all of its commands are available in the latter mode. The tools on this menu facilitate curve adjustments.

- **Keys Menu** - The commands on the Keys menu let you add animation keys and align them to the cursor as well as use soft selection for transforming keys.
- **Time Menu**—Use tools on the Time menu to edit, adjust, or reverse time. The Time menu is available only when Track View is in Dope Sheet mode. These tools are also available on the Time toolbar.
- **Tangents Menu**—The Track View Tangents menu is available only when working in Curve Editor mode. The tools on this menu facilitate managing animation-key tangents.
- **Show Menu**—The Show menu in Track View contains controls for how items appear and are handled in the Controller window.
- **Track View Quad Menus**—Right-clicking the Key window or Hierarchy list brings up a quad menu that offers instant access to tools. The menu is context sensitive, so its contents vary, depending on what is highlighted. For example, when the Hierarchy list is active, you can assign copy and paste controllers, and open properties which you can animate. You can set the Auto Expand and Manual Navigation controls to change the behavior of the Controller window display.

### Curve Editor Introduction

Curve Editor is a Track View mode that allows you to work with motion expressed as function curves on a graph. It lets you visualize the interpolation of the motion: the object transformations that 3ds Max creates between the keyframes. You can easily see and control the motion and animation of the objects in the scene using the keys on the curves and their tangent handles. The alternative mode is Dope Sheet, which lets you work directly with keys instead of curves.

- **Main Toolbar** ➤ ![Curve Editor (Open)](image)
- **Right-click** an object selected in a viewport ➤ Curve Editor
- **Track View** ➤ Editor Menu ➤ Curve Editor
- **Standard menu**: Graph Editors menu ➤ Track View - Curve Editor
- **Enhanced menu**: Animation menu ➤ Motion Editors ➤ Track View - Curve Editor

The Curve Editor interface consists of a menu bar, a toolbar, a Controller window, and a Key window. There is also a time ruler, and navigation and status tools at the bottom of the interface.

**NOTE:** How you zoom and pan in the Key window depends on which interaction mode, 3ds Max or Maya, is active.

You can loop or cycle your animation beyond its range by adding Parameter Curve Out-Of-Range Types from the Curve Editor, as well as by adding Multiplier or Ease Curve onto other animated tracks for added control.

**TIP:** You can also click Show Curves on the track bar to display function curves.
NOTE: To restore the default layout from versions of 3ds Max prior to 3ds Max 2012, open the Track View Toolbar Right-Click Menu and choose Load Layout ➤ Function Curve Layout (Classic).

Editing Keys in Curve Editor

The Curve Editor displays animation as function curves, charting the controllers’ changes of value over time.

- **Main toolbar ➤ (Curve Editor (Open)) ➤ Highlight animated tracks. ➤ Curves are displayed in Key Window.**
- **Graph Editors ➤ Track View - Curve Editor ➤ Highlight animated tracks. ➤ Curves appear in Key window.**
- **Right-click any animated object. ➤ Curve Editor ➤ Curves appear in the Key window.**

Highlighting a controller label displays keys for that item as vertices on the function curve. You can then highlight keys and change their values.

You can add keys to function curves for tracks that are not yet animated. The curves appear as straight lines. When you add a key to a function curve, a controller is created for that track.

Not all controller types display function curves. For example, a TCB Rotation controller doesn't display a function curve, while an Euler XYZ rotation controller shows individual curves for X, Y and Z. Some controllers display individual tracks for each axis, while other controllers combine the three axis values into a single curve.

**Bezier Tangent Handles**

**Spline tangents**

You can use Bezier handles in the Curve Editor to change the shape of the trajectory through a key. To display handles on a key, right-click a key in the Track View Key Window and choose the Spline Tangents option. You can assign the Spline Tangent type only to keys on tracks that use a Bezier controller. This places tangent handles on the keys that you can manipulate horizontally and vertically.

**Procedures**

**To display function curves:**

1. Select an animated object.
2. Right-click the active viewport and choose Curve Editor. The function curves for the object’s animation are displayed in the Key window of the Function Curve Editor.
3. To display additional curves at the same time, from the Track View menu choose Settings ➤ Manual Navigation.
4. Navigate the controller window until you see the additional tracks, and then hold down the Ctrl key and click them.

The curves for all highlighted tracks are displayed together in the Key window.

**Curve Editor Toolbars**

These toolbars are visible or available if the Curve Editor is open, and in general contain controls for editing animation data in the form of function curves.

- **Track View ➤ Curve Editor**

Two different Curve Editor layouts are available: standard and classic. The standard layout provides a streamlined interface designed for efficient function-curve editing, while the classic layout offers more tools by default in a familiar arrangement.

**Curve Editor Toolbars: Standard Layout**
The standard layout appears by default when you open Track View in Curve Editor mode, and displays the following toolbars:

- Key Controls
- Navigation
- Key Tangents
- Tangent Actions
- Key Entry

Also, the standard layout has Filters ➤ Show ➤ Hierarchy off by default, while it's on in the classic layout. To return to this layout from a different one, right-click an empty toolbar area and choose Load Layout ➤ Function Curve Layout.

**Curve Editor Toolbars: Classic Layout**
To access the classic layout, right-click an empty toolbar area and choose Load Layout ➤ Function Curve Layout (Classic). This layout includes these toolbars:

**Upper toolbar**

- Keys
- Key Tangents
- Curves
- Biped

**Lower toolbar**

- Key Stats
- Track Selection
- Navigation

**Related Information**

- Common Track View Toolbars
- Dope Sheet Toolbars

**Definitions**

- **Key Controls Toolbar** - The Key Controls toolbar for the Curve Editor contains tools for moving and scaling keys, drawing curves, and inserting keys.
- **Key Tangents Toolbar** - The Key Tangents toolbar lets you assign tangency to keys. Tangency controls the smoothness and the speed of motion near the key. For more information about tangents, see Tangent Types.
- **Tangent Actions Toolbar** - The Tangent Actions toolbar provides tools for unifying and breaking animation-key tangents.
- **Keys Toolbar (Curve Editor)** - The Keys toolbar for the Curve Editor contains tools for filtering tracks and transforming and editing keys.
Curves Toolbar - The Curves toolbar provides controls for managing key selection and editing.

Biped Toolbar - Tools on the Biped toolbar let you choose which animation curves to display in the Curve Editor. You can toggle between the position and rotation curves, as well as toggle the separate curves representing the X, Y, and Z axes of the current biped selection.

Key Entry Toolbar - The Key Entry toolbar for the Curve Editor contains fields for editing individual keys from the keyboard. It appears by default in the standard Curve Editor, and is similar to the Key Stats toolbar.

Dope Sheet Introduction

The Dope Sheet editor uses Track View to display animation keys over time on a horizontal graph. This graphical display simplifies the process of adjusting animation timing because you can see all keys at once in a spreadsheet-like format. The alternative Track View mode is Curve Editor, which lets you work with interpolation curves in addition to keys.

- Track View ➔ Editors Menu ➔ Dope Sheet
- Right-click an object selected in a viewport ➔ Dope Sheet
- Standard menu: Graph Editors menu ➔ Track View - Dope Sheet
- Enhanced menu: Animation menu ➔ Motion Editors ➔ Track View - Dope Sheet

Classical animation technique uses an exposure sheet, also called an “X” sheet or a Dope Sheet. This vertical chart that serves as instructions to the camera operator. Dialogue and camera actions are indicated in a numbered list that represents each shot, which becomes a single photographed frame of the animated movie. The classical exposure sheet also includes instructions for compositing the cel drawings of animated characters over backgrounds. This device serves as inspiration for the Dope Sheet tool in 3ds Max.

A common use of Dope Sheet is to stagger the movement of a character’s limbs so they don’t all move simultaneously. If you have a crowd of characters, you could use Dope Sheet to shift movements so they don’t all move in unison.

**NOTE:** How you zoom and pan in the Key window depends on which interaction mode, 3ds Max or Maya, is active.

Dope Sheet Menus and Tools

The Dope Sheet editor is similar to the classic X sheet. It displays keyframes over time, only using a horizontal graph (rather than vertical). You can see all the keys in a spreadsheet-type interface. You can select any or all of the keys in a scene, scale them, move them, copy and paste them, and otherwise work...
directly here, rather than in the viewport. You can choose to select the keys for children, or subtree, or both, so you can make simple changes that affect many objects and their keys at once.

Dope Sheet allows for soft-selection of keys which is very useful when working with motion capture data that has keys on every frame.

Dope Sheet provides tools for working directly with time. You can select, cut, copy, paste, and insert and reverse time using the tools on the Time menu.

Like the Curve Editor, Dope Sheet has both a menu bar and toolbars to provide you quick access to tools.

Dope Sheet menu bar

Unlike Curve Editor, Dope Sheet has two modes: Edit Keys and Edit Ranges. These modes affect the display in the Key window.

Edit Keys Mode

When Edit Keys is active, the keyframes are displayed as boxes within rectangles on a grid. The keys are color-coded to show what has been keyframed (position is red, scale is yellow, rotation is green, and so on.)

Colored keys

Dope Sheet keys are now displayed as rectangles within boxes so you can easily spot sub-frame keys, keys that fall in-between frames. Keys that fill the boxes are on the frame, keys that are small rectangles are sub-frame.

Sub-frame keys

Dope Sheet, just like the Curve Editor, allows you to use soft selection on keys. This is extremely useful when you are dealing with massive quantities of keys, such as in motion-capture data files. Combine this with scaling keys for a means to manipulate motion data.

Soft selection of Dope Sheet keys

Edit Ranges Mode

When Edit Ranges is active, the animation tracks are displayed as range bars; no individual keys are visible. Use this mode when you want to change only how long an action takes, or when it starts and ends, rather than particular keys within an animation range.
Edit Ranges mode
Modify Subtree and Modify Child Keys

When working in Dope Sheet mode, you can toggle Modify Subtree and Modify Child Keys. These let you automatically move the tracks for the subtree and the keys for the children, respectively. If you experience a slowdown while working with Dope Sheet, try turning these off and moving the keys manually instead. Modify Subtree is on by default in Dope Sheet, but Modify Child Keys is off.

Time Editing
Dope Sheet offers you a variety of tools for working directly with time. You can select a period of time, which includes all the keys within that period, and then perform different operations on that time segment. You can copy and paste time to loop animations, or reverse time so the animation plays backward. You can insert time to add a space to an animation, or delete time to shorten a motion.

NOTE: For Dope Sheet procedures, see the individual tools and menu choices within the links below.

Dope Sheet Display Optimization
Only tracks displayed in the current field of view are computed, optimizing the responsiveness of the Dope Sheet editor.

Dope Sheet temporarily retains the key caches so tracks that have already been computed as a result of the parent being computed needn't be recomputed. The cache is used instead.

The default auto-navigation settings for the Dope Sheet editor auto-expand only to the node track for the currently selected object. This reduces the number of tracks whose keys need to be displayed and also helps enforce the top-down workflow for which the Dope Sheet editor is designed.

Morphing

Morphing is a term derived from metamorphosis, which means to change physical shape or form.

Morphing makes the clock appear to melt.
The purpose of the morph object in 3ds Max is to create an animated object that changes shape by morphing between two or more objects. Although it appears that a single object is changing form, in reality the morphing process translates the position of the vertices from their arrangement in one object to the arrangement in another, relative to their local coordinate system.

Consequently, all objects chosen to make up a morph object must have the same number of vertices. Typically, you achieve this by cloning an object, and then altering the geometry of the clones without changing their vertex count.

In this section, you can explain Morph Modifier and Morph compound object

Motion Panel

The Motion panel provides tools to adjust the motion of the selected object.

- Select an object. ➤ Command panels ➤ Motion panel
Key timing and easing in and out of a key are parameters that you can adjust with tools on the [Motion panel](#), for example. The [Motion panel](#) also provides an alternative to Track View for assigning animation controllers.

Additional rollouts display in the [Motion panel](#) if an assigned animation controller has parameters. If a Path constraint is assigned to the position track of an object, then a Path Parameters rollout is added to the [Motion panel](#). A Link constraint displays a Link Parameters rollout, a Position XYZ controller displays a Position XYZ Parameters rollout, and so on.

**Trajectories**

Click Trajectories to chart a path that an object will travel along in the viewports. Yellow dots along the path represent frames, giving you an idea of velocity and easing. By turning on Sub-Object Keys, keys can be moved in space, key properties can be changed, the trajectories will reflect all the adjustments you make. You can also convert to and from splines and collapse transforms using trajectories.

**Interface**

**Parameters**

Provides an alternative to [Track View](#) for adjusting transform controllers and key information.

**Assign Controller Rollout**

The Assign Controller rollout assigns and appends different transform controllers to individual objects. You can also assign controllers in Track View.

- Select an object. ➤ [Motion panel](#) ➤ Parameters ➤ Assign Controller rollout

Animation controllers are plug-ins that handle all of the animation tasks in 3ds Max. For a complete list of available animation controllers, see [Assign Controller (Track View)](#).

**Procedures**

**Example: To assign a TCB Rotation controller:**

1. Select an object.
2. On the [Motion panel](#), click Parameters, and open the Assign Controller rollout.
3. Highlight the Rotation track in the Assign Controller list.
4. Click (Assign Controller), choose TCB Rotation from the Assign Rotation Controller dialog, and then click OK to close the dialog and accept the change.

The default Euler XYZ Rotation controller is replaced with the TCB Rotation controller.

**Interface**

**Assign Controller**

Opens the Assign Controller dialog. Available only when a track is highlighted.

**Assign Controller dialog**

Choose a controller from a list of available controllers in this dialog. The Assign Controller dialog lists a subset of the different types of controllers whose members depend on the type of track you've highlighted. For example, only Rotation controllers are available for rotation tracks.
Use Assign Controller in Track View or on the Motion panel to assign animation controllers to any animatable parameter or track.

- **Track View ➤ Controllers Toolbar ➤ Assign Controller**
- **Track View ➤ Highlight a controller track in the Controller window. ➤ Edit menu ➤ Controller submenu ➤ Assign Controller**
- **Track View ➤ Highlight a controller track in the Controller window. ➤ Right-click the track. ➤ Assign Controller**
- **Select an object. ➤ Motion panel ➤ Assign Controller rollout ➤ Highlight a track in the list. ➤ Assign Controller**

Animation controllers and constraints provide powerful tools for animating all the objects and materials in a scene. For example, rather than keyframing the position of an object in your scene, the object can follow a spline using the Path constraint, react to any animated parameter using a Reaction controller, or move to a musical beat using the Audio controller. You can use a List controller to combine controllers with individual weighting. You can drive a single vertex or control point on a complex object by a variety of controllers.

To view lists of available controllers and constraints, see Animation Controllers and Animation Constraints.

**NOTE:** You can also assign controllers and constraints directly from the Animation menu; doing so automatically assigns the item as the child of a List controller.

### Constraints and Controllers

Technically, there is no difference between a controller and a constraint. A constraint is simply a controller that requires the use of a second object. For example, a Path constraint is a controller that requires a spline object for a path.

### Special-Case Controllers

Special-case controllers are not assigned manually with the Assign Controller command. They are applied automatically during certain procedures:

- A Barycentric Morph controller is applied by selecting an object and assigning a Morph modifier:
  - Click Command panel ➤ Geometry ➤ Compound Objects ➤ Morph.

- A Master Point Controller is assigned when animating vertices, control points, or vectors at a sub-object level of an Editable Poly, Editable Mesh, Editable Spline, Editable Patch, NURBS surface, or FFD modifier.

- Slave Controllers can be assigned manually, but are also applied automatically to selected tracks when a Block controller is created in Track View ➤ Global Tracks. A Slave controller transfers key data to a Block controller. See Block Controller.

### Procedures

**Example: To assign an animation controller in Track View:**

1. In the Track View Hierarchy, select one or more parameter items of the same type.
2. From the Edit menu ➤ Controller submenu, choose Assign.
3. Choose a controller type from the Assign Controller dialog.
   - If a parameter has already been animated, then assigning a new controller has one of the following effects:
• The existing animation values are recalculated to produce a similar animation with the new controller. For example, replacing Position XYZ with Bezier Position preserves the animation closely.

• The existing animation values are lost. For example, replacing Smooth Rotation with Noise Rotation discards the Smooth Rotation animation values.

Interface
Choose a controller type from the Assign ... Controller dialog. Depending on the type of track currently highlighted, the dialog lists a subset of the different types of controllers.

Make Default
Makes the highlighted controller the default type for this type of parameter. For example, setting a Float parameter to the Noise Float controller will set Noise Float as the default for all Float parameters. After clicking Make Default, you're prompted to confirm the change.

OK
Assigns the highlighted controller to the highlighted track or tracks. In some cases, doing so opens a parameters dialog for the new controller.

PRS Parameters Rollout

The PRS Parameters rollout provides tools for creating and deleting keys. PRS stands for the three basic transform controllers: Position, Rotation, and Scale.

Procedures
To create a PRS transform key:

1. Select an object ➤ Motion panel ➤ Parameters ➤ PRS Parameters rollout

2. Drag the time slider to the frame where you want to place a key.

3. On the Motion panel, choose Parameters ➤ PRS Parameters rollout.

4. Click one of the following buttons under Create Key PRS Parameters rollout:
   • Click Position to create a Position key.
   • Click Rotation to create a Rotation key.
   • Click Scale to create a Scale key.

If a particular Position, Rotation, or Scale controller doesn't use keys, then that button is not available under Create Key. For example, you can't create Position keys if you're using a Noise Position controller.

Interface
Create Key and Delete Key groups

Creates or deletes a move, rotate, or scale key at the current frame. These buttons become active or inactive depending on the existence of a key type at the current frame.

For example, if you're on a frame containing a Scale key, the Scale button is inactive in the Create column because a key already exists. At the same time, the Position and Rotation buttons are inactive in the Delete column because there are no keys of that type to delete.

**Position/Rotation/Scale**

Determines the contents of the Key Info rollouts that appear below the PRS Parameters rollout on the Motion panel.

**Key Info (Basic) Rollout/Dialog**

The Key Info (Basic) rollout or dialog changes the animation value, time, and interpolation methods of one or more selected keys.

- Select an animated object ➤ Parameters ➤ Key Info (Basic) rollout
- Select an animated object. ➤ Right-click a key on the track bar. ➤ Choose a controller track.
- Make a selection. ➤ Hierarchy panel ➤ IK button ➤ Key Info (Basic) rollout
- Curve Editor ➤ Right-click a key.
- Parameter Collector ➤ Click a Properties button.

On the **Motion panel**, you specify the transform type for which the key info is shown with the **Position/Rotation/Scale** control. Also, if the rollout shows key info for one axis at a time, change the axis for displayed data with the Parameters rollout. For example, with the Position XYZ controller, the Position XYZ Parameters rollout lets you choose the X, Y, or Z axis.

**Procedures**

**To set the tangent type for a key:**

1. Select an object and open the Key Info (Basic) rollout.
2. Use the arrows in the upper-left corner of the dialog to select a key.
3. Choose a tangent type from the In or Out tangent flyouts.

**Interface**

The following parameters are available with the **Bezier Position controller**. The default position controller, **Position XYZ**, shows only one axis at a time, and **TCB Position controller** shows, in addition to X, Y, and Z axis positions, controls for Ease To/From, Tension, Continuity, and Bias. Other controllers differ accordingly.

- **Key number**—Shows the current key number. Click the right or left arrows to go to the next or previous key.
- **Time**—Specifies at what time the key occurs.
- **Time Lock**

Prevents horizontal key movement in Track View Edit modes.
**Value**-Adjusts the position of the selected object at the current key.

![Value Adjustments](image)

**NOTE:** In the Key Info dialog for the Bezier Scale controller, a Lock button is displayed beside the X Scale spinner. If you click Lock X, only the X value affects all three axes of scale. The Y and Z values are ignored and their function curves are not displayed. When X is locked, the Y and Z values aren't affected by changes in the X value. If you click Lock X when all three axes are at identical values, alter the X value, and then unlock X. The Y and Z values remain where they were while X retains its new value.

**Key Tangent Flyouts**-With Bezier controller types, sets the interpolation properties of the In tangent and Out tangent of the key. For details, see **Tangent Types**.

**Tangent Copy buttons**-Use the arrow buttons at either side of the Key Tangent flyouts to copy the tangent type between the tangents of the current key or between the tangents of the previous and next key.

- The left arrow of the In tangent copies to the Out tangent of the previous key.
- The right arrow of the In tangent copies to the Out tangent of the current key.
- The left arrow of the Out tangent copies to the In tangent of the current key.
- The right arrow of the Out tangent copies to the In tangent of the next key.

**Related Information**

- **Key Info (Advanced) Rollout/Dialog**
- **Tangent Types**

You can adjust the tangent type of the Bezier transforms. This means you can adjust the interpolation between keyframes to create particular motion effects. By manipulating tangent types, you can make something hesitate, speed up, slow down, or even stand still.

---

**Key Info (Advanced) Rollout/Dialog**

The Key Info (Advanced) rollout and dialog contain key settings additional to those on the **Key Info (Basic) rollout and dialog**.

- Select an animated object. ➤ **Motion panel** ➤ **Parameters** ➤ **Key Info (Advanced) rollout**
- Make a selection. ➤ **Hierarchy panel** ➤ **IK button** ➤ **Key Info (Advanced) rollout**
- Select an animated object in the viewport. ➤ Right-click a key in track bar. ➤ Choose the name of the controller track such as Sphere01: Z Position. ➤ **Key Info dialog** ➤ **Click Advanced**.
- **Parameter Collector** ➤ **Click a Properties button**. ➤ **Key Info dialog** ➤ **Click Advanced**.

On the Motion panel, you specify the transform type for which the key info is shown with the **Position/Rotation/Scale** control. Also, if the rollout shows key info for one axis at a time, change the axis for displayed data with the Parameters rollout. For example, with the Position XYZ controller, the Position XYZ Parameters rollout lets you choose the X, Y, or Z axis.

With the Key Info (Advanced) settings, you can control velocity in three ways:

- You can specify the absolute velocity at a key using the In/Out fields.
- You can average velocity over a time period using Normalize Time.
With certain controller types, you can force constant velocity from one component key to the next using Constant Velocity. If you are creating Path animation, you can force constant velocity by placing a Normalize Spline modifier on the spline used as a path.

Procedures

To set normalize time for a key:

1. Select an object and choose a key to normalize. You can use the arrows on the Key Info (Basic) rollout to step through keyframes.

2. On the Key Info (Advanced) rollout, click Normalize Time. The key is moved in time to average the velocity through the key.

Interface

The following parameters are available with the Bezier Position controller. The default position controller, Position XYZ, shows only one axis at a time, and TCB Position controller shows, in addition to X, Y, and Z axis positions, controls for Ease To/From, Tension, Continuity, and Bias. Other controllers differ accordingly.

### In/Out

The In field specifies the rate of change as the parameter approaches the key. The Out field specifies the rate of change as the parameter leaves the key.

- These fields are active only for keys that use the Spline tangent type.
- The number in the field is the rate of change expressed as parameter units per tick. By changing the two values for X, Y, and Z you are changing the length and angle of the tangent handle.

### Lock button

Changes one Spline tangent by changing the other an equal but opposite amount. For example, if you click the Lock button and the In value is 0.85, then the Out value is -0.85.

### Normalize Time

Averages the position of the keys in time and applies them to any consecutive blocks of selected keys. Usefull if you have an object that speeds up and slows down repeatedly, and you want to smooth out the motion.

### Constant Velocity

When on, interpolates values between the key and the next one so that the object moves at a constant velocity across that curve segment. Available only with certain controller types, such as Bezier.

### Free Handle

Used for automatically updating the length of the tangent handle. When this is turned off, the length of the tangent is at a fixed percentage from its neighboring key. As you move a key, the handles adjust to stay the same percentage away from the neighboring keys. When this is turned on, the handle lengths are based on time lengths.

**Trajectories**

Provides tools for working with objects’ trajectories.

**Trajectories**

The Trajectories feature displays the path an object travels over time. This is useful for seeing at a glance how the object moves with respect to other objects in the scene during an animation.
actually having to play the animation. Trajectories also lets you adjust the path directly and convert it to and from other formats.

- Select an object ➤ Motion panel ➤ Trajectories

Scooter following a trajectory

**NOTE:** By default, an object's trajectory is visible in the viewports only when the object is selected and Trajectories mode is active. To make the object's trajectory visible at all times, turn on the Trajectory checkbox under Display in the Object Properties dialog or on the Display panel ➤ Display Properties rollout.

Using trajectories, you can do the following:

- Display the 3D path for selected object’s position tracks.
- Insert and delete keys from the path.
- Move, rotate, and scale keys on the path.
- Convert the path to a spline object.
- Derive a new path from a spline object.
- Collapse any transform controller into editable keys.

Values under Sample Range are used in the Spline Conversion and Collapse Transform functions.

**NOTE:** You can assign the four principal Trajectories functions to keyboard shortcuts and other custom UI items. The following actions are available via Customize User Interface:

- **Trajectory Add Key Mode Toggle**: Enters and exits Add Key mode.
- **Trajectory Delete Key**: Activates the Delete Key function on a one-time basis.
- **Trajectory Key Mode Toggle**: Enters and exits the Keys sub-object level for direct editing of animation keys via transformation of the trajectory keys.
- **Trajectory Toggle**: If one or more objects are selected, this enters and exits Trajectories mode on the Motion panel.

**Procedures**

**To display an object's trajectory:**

1. ✉ Select an animated object that moves over time.
2. ➤ Right-click the object and choose Properties. Trajectory is not available.
3. ✉ In the Display Properties group, click By Layer to change this button to By Object. Skip this step if By Object is already displayed.
Trajectory becomes available.

4. Turn on Trajectory, then click OK. The Trajectory is displayed as a red line with white squares and dots. The white squares are keys, the white dots are in-betweens.

**To add a key to a trajectory:**

1. Select an object.
2. Display the trajectory by following the previous steps.
3. On the **Motion panel**, click Trajectories.
4. Click Sub-Object to activate Keys and enable editing.
5. Click Add Key. The button highlights.
6. Click the trajectory. Wherever you click the trajectory a key will be added.
7. Right-click the key and select Key Info from the right-click menu. In the Key Info dialog, you can change the In and Out values for the in-betweens on either side of the key. This allows you to use the trajectory key to create the illusion of hesitation or acceleration. You can click repeatedly to add many keys in this mode.

**To delete a key from a trajectory:**

1. Select a key on a trajectory. You can click it, or use window selection.
2. On the **Motion panel** Trajectories rollout, be sure Add Key is turned off.
3. On the **Motion panel** Trajectories rollout, click Delete Key. 3ds Max deletes the key.

**To transform keys on a trajectory:**

1. Select one or more objects.
2. On the **Motion panel**, click Trajectories.
3. Click Sub-Object to activate Keys and enable editing.
4. Select one or more keys and use the transform tools on the Main toolbar to move, rotate, or scale the selected keys.

**To set an object to use a spline as its animation path:**

1. Create or open a scene that contains any object and a spline to use as an animation path.
2. Select the object and activate Trajectories mode.
3. Click Convert From and then select the spline. The trajectory is created from the spline and the object moves to its start point. If you play or scrub the animation at this point, the object moves along the path.
NOTE: Any existing animation keys for the object will be incorporated at their current locations into
the new path. So, for best results, use a non-animated object.

**Interface**

**Sub-Object**

Enables key editing. Use the Move, Rotate, and Scale transforms to change the location of a key(s) displayed on a trajectory.

**Trajectories rollout**

**Delete Key**

Deletes the selected key(s) from the trajectory.

**Add Key**

Adds key(s) to the trajectory. This is a modeless tool. When you click this button once, you can then add any number of keys by clicking the trajectory line in the viewport one or more times in succession. To exit Add Key mode, click the button again.

**Sample Range group**

**Start Time/End Time**

Specifies the interval for the conversion. If you're converting from position keyframes to a spline object, this is the time interval for which the trajectory will be sampled. If you're converting from a spline object to position keys, this is the interval over which the new keys will be placed.

**Samples**

Sets the number of samples for the conversion. When converting in either direction, the source is sampled at regular intervals, and keys or control points are created on the target object.

**Spline Conversion group**

**Convert To/Convert From**

Converts keyframe position tracks to and from spline objects. This enables you to create a spline trajectory for an object and then convert that spline to keyframes for that object's position track in order to do various keyframe-specific functions (such as applying constant velocity to the keys and normalizing the time). Or, you can convert an object's position keyframes into a spline object.

**TIP:** Convert To and Convert From can be used to move an object along a path without using a path constraint.

**Collapse Transform group**

Generates keys based on the current transformation of the selected object. You can apply this for any type of transform controller assigned to an object, but the main purpose of this function is to "collapse" a parametric transform effect, such as one generated by a Path constraint, into standard, editable keys.

**Collapse**
Collapses the transform of the selected object.

**Position, Rotation, Scale**

Specifies which transforms you want to collapse.

You must choose at least one checkbox to activate the Collapse button.

**Simulating Particles**

**Particle Systems**

Particle systems are useful for a variety of animation tasks. Primarily, they're employed when animating a large number of small objects using procedural methods; for instance, creating a snowstorm, a stream of water, or an explosion. 3ds Max provides two different types of particle systems: event-driven and non-event-driven. The event-driven particle system, **Particle Flow**, tests particle properties, and, based on the test results, sends them to different events. Each event assigns various attributes and behaviors to the particles while they're in the event. In the **non-event-driven systems**, particles typically exhibit consistent properties throughout the animation.

*Left: Fountain spray created as a particle system*

*Insets on right: Wind space warp changes the direction of fountain spray*

**IMPORTANT:** Particle systems can involve a great many entities, each of which is potentially subject to any number of complex calculations. For this reason, when using them for advanced simulations, you should have a very fast computer and as much memory as possible. Also, a powerful graphics card helps speed the display of particle geometry in the viewports. Even so, it's still easy to overburden the system; if you encounter loss of responsiveness, wait for the particle system to finish its calculations, and then reduce the number of particles in the system, implement a cache, or use other methods to optimize performance.

**Which Particle System to Use?**

Having access to a wealth of particle systems in 3ds Max leads to the need to decide which system to use for a particular application. In general, for a simple animation, such as falling snow or a water fountain, setup is faster and easier with a non-event-driven particle system. With more complex
animations, such as an explosion that generates different types of particles over time (for example: fragments, fire, and smoke), use Particle Flow for greatest flexibility and control.

Definitions:

- **Particle Flow**
  Particle Flow is a versatile, powerful particle system for 3ds Max. It employs an event-driven model, using a special dialog called Particle View. In Particle View, you combine individual operators that describe particle properties such as shape, speed, direction, and rotation over a period of time into groups called events. Each operator provides a set of parameters, many of which you can animate to change particle behavior during the event. As the event transpires, Particle Flow continually evaluates each operator in the list and updates the particle system accordingly.

Particle Flow is a versatile, powerful particle system for 3ds Max. It employs an event-driven model, using a special dialog called Particle View. In Particle View, you combine individual operators that describe particle properties such as shape, speed, direction, and rotation over a period of time into groups called events. Each operator provides a set of parameters, many of which you can animate to change particle behavior during the event. As the event transpires, Particle Flow continually evaluates each operator in the list and updates the particle system accordingly.

To achieve more substantial changes in particle properties and behavior, you can create a flow. The flow sends particles from event to event using tests, which let you wire events together in series. A test can check, for example, whether a particle has passed a certain age, how fast it's moving, or whether it has collided with a deflector. Particles that pass the test move on to the next event, while those that don't meet the test criteria remain in the current event, possibly to undergo other tests.

**NOTE:** Operators and tests are known collectively as actions.

How Particle Flow Works

Particle View is the primary interface for building and modifying Particle Flow systems. The first event in the system is always a global event, whose contents affect all particles in the system. It has the same name as the Particle Flow source icon.

By default, the global event contains a single Render operator that specifies rendering properties for all particles in the system. You can add other operators here to have them act globally, such as Material, Display, and Speed. When you use an operator globally, be sure not to use the same operator locally (that is, in any other events in the system) to avoid potential conflicts.

The global event also serves as the Particle View representation of the particle system. You can create a new system by duplicating this event, or by adding an Empty Flow or Standard Flow. Conversely, if you clone the Particle Flow icon in a viewport, or add a new PF Source, the new system appears in Particle View as well.

The second event is called the birth event, because it must contain a Birth operator. The Birth operator should exist at the top of the birth event, and in no other place. The default birth event also contains a number of operators that act locally to specify properties of particles while in that event. The default particle system provides a basic global event and birth event that serve as a useful starting point for creating your own system. If you like, you can instead start with an empty system that lets you build a particle system from scratch.
1. Event display
2. Global event
3. Particle diagram
4. Birth event
5. Depot
6. Navigator

To add an action to the particle diagram, you drag it to the event display from the depot (the area at the bottom of the Particle View dialog). If you drag an action to an event, you can add it to the event or replace an existing action, depending on where you drop it. If you drop it in an empty area, it creates a new event. Then, to customize the action, you click its event entry, and then edit its settings in the parameters panel at the side of Particle View.

To add complexity to the particle system, you can add a test to an event, and then wire the test to another event. You can adjust the test parameters to affect particle behavior, as well as determine whether specific conditions exist. When particles meet these conditions, they become eligible for redirection to the next event.

Particle Flow provides a number of tools for determining where in the system particles currently reside, including the ability to change particle color and shape on an event-by-event basis. You can also easily enable and disable actions and events, and determine the number of particles in each event. To speed up checking particle activity at different times during the animation, you can cache particle motion in memory. Using these tools, plus the ability to create custom actions with scripting, you can create particle systems of a level of sophistication previously unachievable.

Flows

The Flows category provides shortcuts for creating different kinds of initial particle-system setups. To use a flow, simply drag it from the depot to the Particle View main window. The available flows are listed at the end of this topic.
The Particle Flow flows in the Particle View depot

- **Preset Flow**—Preset Flow merges a previously saved Particle Flow setup into the current scene. It allows you to use the flow as an event within your current flow, or as a starting point for a new particle system.

- **Empty Flow**—Empty Flow provides a starting point for a particle system consisting of a single global event containing a Render operator. This lets you build a system completely from scratch, without having first to delete the default operators provided by the Standard Flow system.

- **Standard Flow**—Standard Flow provides a starting point for a particle system consisting of a global event containing a Render operator, wired to a birth event containing a Birth, a Position, a Speed, a Rotation, a Shape, and a Display operator, with all parameters set to default values. This is the same system that 3ds Max creates automatically when you add a Particle Flow icon to the viewport.

- **One Click Flow**—One Click Flow provides a starting point for a particle system that uses cached, external particle data in the form of Maya nCache files. The flow comprises a Birth File operator, a Material Static operator for assigning a material to the particles, a Shape operator, and a Display operator.

**Video Post**

- Video Post, available from the Rendering menu, lets you combine (composite) and render output of various types of events, including the current scene, bitmap images, image-processing functions, and so on.

- A video post queue can include scene geometry, background images, effects, and masks for compositing them.

- **The result of video post: a composited frame**

- Video Post is a self-contained, modeless dialog, similar in appearance to Track View. The edit window of the dialog shows when each event occurs in the finished video. Each event is associated with a track that has a range bar.
The Video Post dialog contains the following window components:

- **Video Post Queue**: Shows the sequence of post-production events.
- **Video Post Status Bar/View Controls**: Shows information about the active Video Post controls and lets you control the display of tracks in the event tracks area.
- **Video Post Toolbar**: Provides Video Post commands.

### Video Post Queue

Video Post Queue provides a hierarchical list of the images, scenes, and events to be composited.

- Rendering menu ➤ Video Post ➤ Video Post window ➤ Video Post Queue

The Video Post queue in the Video Post dialog is similar to other hierarchical lists in the Track View and Material Editor. In Video Post, the list items are images, scenes, animations, or external processes that together make up the queue. The items in the queue are called events.

The order that the events appear in the queue is the order in which they are executed, from top to bottom. Consequently, to correctly composite an image, the background bitmap must appear before, or above, the image that is to overlay it.

There is always at least one item in the queue (a placeholder labeled Queue). It is the queue's parent event.

The queue can be linear, but some kinds of events, such as Image Layer, combine other events and become their parent.

### Procedures

**To add an event to the queue:**

- Click an event button.

When you add an event, a dialog displays where you can specify settings for that event. The settings offered on the dialog depend on the type of event; some events have different kinds of subtypes.

In general, the new event appears at the end of the queue - but some kinds of events require that you first select one or more events in the queue. An event button is unavailable if the selection in the queue (or the absence of one) is not legal input to the button's type of event.

To highlight an event already in the queue, click its icon, label, or range-bar area.

**To delete any event in the queue:**

- Select the event and press the Delete key.

You can delete both enabled and disabled events, which are unavailable.

**To switch the positions of two events in the queue:**

1. Highlight both events.
2. Click ![Swap](Swap). This operation might not be allowed if the result would be impossible to execute. At the top level of the queue, you can almost always swap events; at lower levels, an event's output must be legal input to its parent event.

**To edit an event in the queue, do one of the following:**
1. Select the event and click *Edit Current Event*.
2. Double-click the event name.
3. Double-click the event's range-bar area in the edit window.

Use one of the second two methods for disabled events

**Video Post Status Bar / View Controls**

The Video Post Status Bar contains an area for prompt and status information and for buttons to control the display of tracks in the event tracks area.

- Rendering menu ➔ Video Post ➔ Video Post Status Bar Interface

**Prompt Line**

Displays instructions for using the currently selected function.

**Status (Start, End, Frames, Width, Height)**

<table>
<thead>
<tr>
<th>S</th>
<th>E</th>
<th>F</th>
<th>W</th>
<th>H</th>
</tr>
</thead>
<tbody>
<tr>
<td>5.0</td>
<td>251</td>
<td>202</td>
<td>720</td>
<td>406</td>
</tr>
</tbody>
</table>

Displays the Start frame and End frame for the current event, the total number of frames and the output resolution of the entire queue.

- **S/E**: Shows start and end frames of the selected track. If no track is selected, shows the start and end frames of the entire queue.
- **F**: Shows the total frames in the selected track or for the entire queue.
- **W/H**: Shows the width and height of the image that results from the rendering of all the events in the queue.

**Navigation buttons**

- **Pan**: Lets you drag horizontally in the event tracks area to shift the view left and right.
- **Zoom Extents**: Adjusts the size of the event-track area horizontally so that all the frames of the longest track bar are visible.

Use Zoom Extents to quickly reset the display to show all frames after zooming in on a selection of frames with the Zoom Time button.

- **Zoom Time**: Displays a greater or lesser number of frames in the event tracks area, allowing you to scale or zoom the display. The time ruler displays the current time display unit.

  - Drag horizontally in the event tracks area to zoom time.
  - Drag right to display fewer frames in the track area (zoom in).
  - Drag left to display more frames in the track area (zoom out).

- **Zoom Region**: Magnifies a region that you define by dragging a rectangle in the event tracks area.

**Useful Video Post Procedures**
There are some tasks that you will use Video Post for more than others. This primer describes some of the more common sequences you'll find yourself using Video Post to create. The procedures are outlined in their simplest forms.

- Rendering menu ➤ Video Post

**Procedures**

**Example: Make an object glow:**

One of the most common things you'll want to do with the Glow filter is make an object glow. Here's how to do it in its simplest form.

1. In the Perspective viewport, create a Sphere with a radius of about 30.
2. Choose Rendering ➤ Video Post.
3. Click Add Scene Event and set the view to Perspective. Click OK to close the Add Scene Event dialog.
4. Click Add Image Filter Event and choose Lens Effects Glow from the Filter Plug-In list. Click OK to close the Add Image Filter Event dialog.
5. Click (Add Image Output Event) and then click Files.
6. Set the output file format to BMP Image File and enter a filename like MyGlow. Click Save when you've set the name and format.
7. Click OK to accept the default setting on the BMP configuration dialog. Then click OK to close the Add Image Output Event dialog.
8. Right-click the Sphere to bring up the Quad Menus and select Properties.
9. Set the Object Channel in the G-Buffer group to 1 and click OK.
10. Click (Execute Sequence).
11. Click Render on the Execute Video Post dialog.

You'll see the glowing sphere in the render window.

**Video Post Toolbar**

The Video Post Toolbar contains tools for handling **Video Post** files (VPX files) and for managing the individual events displayed in the **Video Post** queue and event tracks area.

- Rendering menu ➤ **Video Post** toolbar

**Topics in this section**

- **New Sequence**- The New Sequence button creates a new **Video Post** sequence by clearing existing events from the queue.
- **Open Sequence**- The Open Sequence button opens a **Video Post** sequence stored on disk.
- **Save Sequence**- The Save Sequence button saves the current **Video Post** sequence to disk.
- **Edit Current Event**- The Edit Current Event button displays a dialog that lets you edit the properties of the selected event. The dialog depends on the type of event you've selected. The controls in the edit dialogs are the same as those in the dialog you use to add that type of event.
- **Delete Current Event**- The Delete Current Event button deletes the selected event from the **Video Post** Queue.
- **Swap Events**- The Swap Events button switches the position of two selected events in the queue.
- **Execute Sequence**- You execute the Video Post queue as the final step in creating a post-produced video. Execution is different from rendering because rendering is done for scenes only and you can use Video Post to composite images and animations without including the current 3ds Max scene.
- **Configure Presets**- If you use the Custom format for Execute Sequence, you can change the values for any preset resolution button by right-clicking the button.
- **Edit Range Bar**- The Edit Range Bar provides editing functions for the range bars that appear in the event tracks area.
- **Align Selected Left**- The Align Selected Left button left-aligns two or more selected range bars.
- **Align Selected Right**- The Align Selected Right button right-aligns two or more selected range bars.
- **Make Selected Same Size**- The Make Selected Same Size button makes all selected events the same size as the current event.
- **Abut Selected**- The Abut Selected button places the selected events end-to-end, so that when one ends the next one starts.
- **Add Scene Event**- The Add Scene Event button adds the scene in the selected camera viewport to the queue. A Scene event is a view of the current 3ds Max scene. You can choose which view to display and how to synchronize the scene with the final video. Like Image Input events, Scene events place an image in the queue, but a Scene event is the current 3ds Max scene and it must be rendered when you execute the Video Post queue. The scene is rendered exactly as it would be by the scanline renderer, with the additional options listed below. The resulting scene image has an alpha channel.
- **Add Image Input Event**- The Add Image Input Event adds a still or moving image to the scene. Image Input events place an image in the queue, but unlike Scene events, the image is either a file that was saved beforehand or a device-generated image.
- **Add Image Filter Event**- The Add Image Filter Event provides image processing for images and scenes. Several kinds of image filters are provided, see list below. For example, the Negative filter inverts the colors of an image and the Fade filter fades an image in or out over time.
- **Add Image Layer Event**- The Add Image Layer Event adds a compositing plug-in to layer the selected images in the queue.
- **Add Image Output Event**- The Add Image Output Event provides controls for editing an output image event.
- **Add External Event**- An External event is typically a program that performs image processing. It can also be a batch file or utility that you want to run at a specific point in the queue, or a way to transfer images from or to the Windows clipboard.
- **Add Loop Event**- Loop events cause other events to repeat over time in the output video. They control sequencing, but perform no image processing.

**Filter Events**

Filter events provide image processing for images and scenes. The topics in this section describe the filter events that are available in Video Post.
Definitions

- **Contrast Filter** - The Contrast filter allows you to adjust the contrast and brightness of an image.
- **Fade Filter** - The Fade filter fades an image in or out over time. The rate of the fade is determined by the length of the Fade filter's time range.
- **Image Alpha Filter** - The Image Alpha filter replaces the image's alpha channel with the channel specified by the filter mask.
- **Lens Effects Filters** - The Lens Effects filters add realistic camera flares, glows, gleams, glimmers, and depth-of-field blurring to your scenes. Lens Effects can affect an entire scene or can be generated around specific objects in your scene.
- **Negative Filter** - The Negative filter inverts the colors in the image, making it negative like a negative color photograph.
- **Pseudo Alpha Filter** - The Edit Pseudo Alpha filter creates an alpha channel for the image based on the image's first pixel (the upper-left corner pixel). All pixels that have the same color as this pixel become transparent.
- **Simple Wipe Filter** - The Simple Wipe filter reveals or erases the foreground image with a wipe transition. Unlike the **Wipe Layer compositor**, Wipe Filter wipes across a fixed image.
- **Starfield Filter** - The Starfield filter generates a realistic starfield with optional motion blur. The Starfield filter requires a camera view. Any motion of the stars is a result of camera motion.

Layer events

Layer events composite two events. They can also create a transition from one event to the event that follows. The topics in this section describe the layer events that are provided with **Video Post**.

definitions

- **Alpha Compositor** - The Alpha compositor composites the two images using the alpha channel of the foreground image. The background image appears in areas where the foreground image's alpha channel is transparent.
- **Cross Fade Compositor** - The Cross Fade compositor composites the two images over time, cross-fading from the background image to the foreground image. The rate of the cross fade is determined by the length of the Cross Fade Transition filter's time range.
- **Pseudo Alpha Compositor** - The Pseudo-Alpha compositor composites a foreground image against the background by creating an alpha channel for the foreground image based on the foreground image's upper-left-corner pixel. All pixels in the foreground image that use this color become transparent.
- **Simple Additive Compositor** - The Simple Additive compositor composites the two images using the second image's intensity (HSV value) to determine transparency. Areas of full intensity (255) are opaque; areas of zero intensity are transparent; and areas with intermediate transparency are translucent.
- **Simple Wipe Compositor** - The Simple Wipe compositor reveals or erases the foreground image with a wipe transition. Unlike the **Wipe filter**, the Wipe layer event moves the image, sliding it in or out.